Few little bugs in client software 1.0.8?


#1

Hello,

I think there are possibly a few bugs in the client software 1.0.8.

The prehistory (sorry in advance for my bloody english):
I tried to connect my ledger nano under Windows 10 with the beta client version 1.0.20. During that I got an error message “unable to connect to ledger nano”

I then tried the online client and the connection to the ledger worked. After that I made a client update to 1.0.8 (unfortunately without first uninstalling the beta client). According to the program list the new client was installed, but the query of "settings - info" in the cloient still showed version 1.0.20.

I tried to deinstall the client via “apps & features” of windows 10, the process started, the admin password was asked, but the deinstallation did not start after putting the password in. The second attempt for deinstallation was via the app list, which appears when clicking on the windows button. Selscting the waves-app, right mouse button - uninstall - input Admin-password … this time the deinstallation seems to work, the program does not appear under “apps & features” any more.

Then the disillusionment: in the registry there are still at least 4 entries of waves in some different folders …

Computer \ HKEY_CLASSES_ROOT \ waves
Computer \ HKEY_CURRENT_USER \ Software \ Classes \ waves
Computer \ HKEY_USERS \ S-1-5-21-936472587-109948910-1962732913-1002 \ Software \ Classes \ waves
Computer \ HKEY_USERS \ S-1-5-21-936472587-109948910-1962732913-1002_Classes \ waves \ shell \ open \ command

After restarting the computer, I tried the entire process again, with the same results…

  1. The client 1.0.8 shows under version-info the version 1.0.20 - which is obviously wrong. Regardless of this it seems that the client works well - including the import / connection to the ledger nano.

  2. The program can be deleted only via the microsoft button and not via apps & features, the deletion is only superficial and “unclean” because there are still entries in the registry

  3. When setting up the Ledger connection, you have to confirm a message that a restore in case of deinstallation of the client is only possible with a backup phrase. But you have no backup phrase, because you confirmed the import/connection with the buttons on the ledger. I have not tried what will happen if I uninstall / install the client again. Maybe the message is wrong and the ledger-connection will work again, maybe the procedure is wrong … dont know. Possibly I’ll try that later, but if anyone has some experience I would like to save time ; ).

best regards to the community and to all who likes waves

… and a kindly request to the developer for creating a working uninstall-procedure :slight_smile:

Wokcoiner

P.S: I could’nt find any contact-info at the waves-webpage (otherwise I had sent my observations and some screenprints via e-mail : )