New node will not start


#1

Hello, I have a new node machine, frershy installed UBUNTU server 1604, with all updates done.

Node refuses to start with the following output ;

Oct 23 12:38:38 Pine2GO waves[32345]: Java HotSpot™ 64-Bit Server VM warning: G1 GC is disabled in this release.
Oct 23 12:38:44 Pine2GO waves[32345]: INFO  c.w.Application$ - Starting…
Oct 23 12:38:51 Pine2GO waves[32345]: INFO  a.event.slf4j.Slf4jLogger - Slf4jLogger started
Oct 23 12:38:52 Pine2GO waves[32345]: INFO  c.w.Application$ - Waves v0.14.6 Blockchain Id: W
Oct 23 12:38:52 Pine2GO waves[32345]: ERROR c.w.actor.RootActorSystem$ - Error while initializing actor system wavesplatform
Oct 23 12:38:52 Pine2GO waves[32345]: java.lang.Exception: Could not load any of the factory classes: org.fusesource.leveldbjni.JniDBFactory, org.iq80.leveldb.imp
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.db.LevelDBFactory$.$anonfun$load$5(LevelDBFactory.scala:35)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at scala.Option.getOrElse(Option.scala:121)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.db.LevelDBFactory$.load(LevelDBFactory.scala:35)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.db.LevelDBFactory$.factory$lzycompute(LevelDBFactory.scala:10)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.db.LevelDBFactory$.factory(LevelDBFactory.scala:10)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.db.package$.openDB(package.scala:22)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.Application.<init>(Application.scala:58)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.Application$.$anonfun$main$4(Application.scala:457)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.Application$.$anonfun$main$4$adapted(Application.scala:431)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.actor.RootActorSystem$.start(RootActorSystem.scala:25)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.Application$.main(Application.scala:431)
Oct 23 12:38:52 Pine2GO waves[32345]: #011at com.wavesplatform.Application.main(Application.scala)
Oct 23 12:38:53 Pine2GO systemd[1]: waves.service: Main process exited, code=exited, status=1/FAILURE
Oct 23 12:38:53 Pine2GO systemd[1]: waves.service: Unit entered failed state.
Oct 23 12:38:53 Pine2GO systemd[1]: waves.service: Failed with result ‘exit-code’.

the machine runs a Pine 64 on a mounted disk (/mnt/waves)
here is my aplication.ini :

options from build

-J-Dwaves.directory=/mnt/waves
-J-server
-J-Xms1g
-J-Xmx2g
-J-XX:+ExitOnOutOfMemoryError
-J-XX:+IgnoreUnrecognizedVMOptions
-J–add-modules=java.xml.bind
-J-XX:+UseG1GC
-J-XX:+UseNUMA
-J-XX:+AlwaysPreTouch
-J-XX:+PerfDisableSharedMem
-J-XX:+ParallelRefProcEnabled
-J-XX:+UseStringDeduplication

here is my /lib/systemd/system/waves.service:
[Unit]
Description=Waves node
Requires=network.target

[Service]
Type=simple
EnvironmentFile=/etc/default/waves
ExecStart=/usr/share/waves/bin/waves
 -J-Dwaves.directory=/mnt/waves
 -Dlogback.file.directory=/var/log/waves
 -Dlogback.pattern="%%-5level %%logger{26} - %%msg%%n"
 – /etc/waves/waves.conf

Restart=always
RestartSec=60
RestartPreventExitStatus=38
SuccessExitStatus=143
User=waves
PermissionsStartOnly=true
TimeoutStopSec=300

[Install]
WantedBy=multi-user.target

and finally here is my waves.conf:

Waves node settings

waves {

P2P Network settings

network {
known-peers = [
list of peers]

Network address

bind-address = “0.0.0.0”

Port number

port = 6868

Node name to send during handshake. Comment this string out to set random node name.

node-name = “strignname”

String with IP address and port to send as external address during handshake. Could be set automatically if uPnP is enabled.

declared-address = “1.2.3.4:6868”

;}

Wallet settings

wallet {
Password to protect wallet file
password = “string”

Wallet seed as BASE58 string

seed = “long base58string”
}

Blockchain settings

blockchain.type = MAINNET

Matcher settings

matcher {

Enable/disable matcher

enable = no
}

Node’s REST API settings

rest-api {

Enable/disable node’s REST API

enable = no

}

features {
supported = [2] # NG
;}

checkpoints.public-key = “string”
}

I have googled it a little, but could not find any convincing answers.


#2

r the up, but do someone have a clue on this ?