Problem node no generate

Nobody is able to give me other suggestions?

Here you can download a recent valid state from wavesplatform site: http://blockchain.wavesnodes.com

I use on the fly downloading + unpacking (stop waves and rm -r your data dir):

wget -qO- http://blockchain.wavesnodes.com/blockchain_last.tar | tar xv -C /your/waves/dir/with/data/dir

The syncing from the genesis is a pain.

1 Like

without tar’s v switch it will be a bit faster:)

1 Like

Thanks ikardanov.
Thanks Hoshingen.
Thanks deemru.
Thanks brox.

It seems to work.
Now who knows when the weather for the next block …

How long does it take to get a block?
The others have already started to get the blocks, after switching to 0.16.2
I do not understand.

Consider to read: How long until founding a block

1 Like

thank you
So my node should produce 18 blocks.
In reality, before the fork, the production was 10 - 14 blocks.
Then the fork stopped my knot for 30 days.
Now the node is updated to 0.16.2 and as required “rebuild the state database. Node will not run on the old state”.
My expectation is now 8 days, I guess I’ll have to wait again.
With 8 days it should have been at least 3 - 2 blocks.

In probabilities world, there is no “should”. You can have zero in several months and can have 10 blocks in a single day

Yes I understand the world of probalilities but, there is a node that has 607 waves and has produced a block in the last 24 hours. Am I wrong or to start a node, do we need 1000 waves?
I have 21000 and the desert has been behind me for 6 weeks.
Others with this budget are already in production.
Did I realize the wrong steps for my node without realizing it?

This is my waves.conf
Did I do something wrong?
wavesconf_scudonode.pdf (20.3 KB)

Ok, my node has something wrong, no blocks.
Above my waves.conf configuration file.
Could anyone take a look?
It is now clear that something is not going as it should.

You can check your node status by its API:

If you have API key, you can even check http://104.248.28.128:6869/debug/minerInfo at http://104.248.28.128:6869/api-docs/index.html#!/debug/minerInfo

For now i did not find any problems with your node, please check minerInfo to be sure.

Provided API key is not correct

Yes, noone should know you API key except you, and you should provide it to API to have access to restricted parts of API.

I’m sorry.
I have API key, only I know.
I entered it and returns “Provided API key is not correct”.

Try following:

  1. remove miner {} section completely
  2. change bind-address = “104.248.28.128” to bind-address = “0.0.0.0”

Also, when it says api key is incorrect, try to enter original key (not hashed). Default is ‘ridethewaves!’

So these guides are obsolete?


If I remove the miner, then how does the node find the blocks?
This morning I configured waves.conf like this:

Waves node settings

waves {

P2P Network settings

network {
known-peers = [
“13.228.86.201:6868”
“13.229.0.149:6868”
“18.195.170.147:6868”
“34.253.153.4:6868”
“35.156.19.4:6868”
“52.50.69.247:6868”
“52.52.46.76:6868”
“52.57.147.71:6868”
“52.214.55.18:6868”
“54.176.190.226:6868”
]

# Network address
bind-address = "104.248.28.128"

# Port number
port = 6868

# Node name to send during handshake. Comment this string out to set random node name.
node-name = "ScudoNode scudoplatform.com"

# String with IP address and port to send as external address during handshake. Could be set automatically if uPnP is enabled.
declared-address = "104.248.28.128:6868"

}

Wallet settings

wallet {
# Password to protect wallet file
password = “MY PASSWORD”

# Wallet seed as BASE58 string
seed = "MY SEED (BASE58)"

}

Blockchain settings

blockchain.type = MAINNET

miner {
# Enable/disable block generation
enable = yes

# Required number of connections (both incoming and outgoing) to attempt block generation. Setting this value to 0
# enables "off-line generation".
quorum = 1

# Enable block generation only in the lastblock if not older the given period of time
interval-after-last-block-then-generation-is-allowed = 1d

# Interval between microblocks
micro-block-interval = 5s

# Mininmum time interval between blocks
minimal-block-generation-offset = 1001m

# Max amount of transactions in key block
max-transactions-in-key-block = 0

# Max amount of transactions in micro block
max-transactions-in-micro-block = 255

# Miner references the best microblock which is at least this age
min-micro-block-age = 6s

}

Matcher settings

matcher {
# Enable/disable matcher
enable = no

# Matcher's account address
# account = ""

# Matcher REST API bind address
bind-address = "127.0.0.1"

# Matcher REST API port
port = 6886

}

Node’s REST API settings

rest-api {
# Enable/disable node’s REST API
enable = yes

# Network address to bind to
bind-address = "127.0.0.1"

# Port to listen to REST API requests
port = 6869

# Hash of API key string
api-key-hash = "FcBeRAofWykTV6FicQJxNdEspoaqYJHyHE6uSWidMGC8"

}

features {
supported = [9, 10] # NG
}

checkpoints.public-key = “CkKPNm6JqeEaFodh4bW3VceA3mms4KcFdtEuuJ2yZnLA”
}

include “local.conf”

I did as you told me.
Continue to return: “Provided API key is not correct”.
Following the Russian video, api reset is not set.
Apart from api reset the node looks ok, I could leave waves.conf as in the Russian video, obviously with my data.
Following the English video it seems that to set reset api other commands are needed.
I think I leave api reset set to “no”, I should better digest simpler things first.
Now that I’ve played a lot with waves.conf, is it better to delete everything and start from scratch or change the file and run restart is enough?

Like I said, my node does not have miner section at all and it generates blocks succesfully: https://w8io.ru/brox_aarch64/t/0
35 blocks per 2 months with 21k generating amount.

Have you also activated api reset?
If so, I will change in this sense.