Unable to configure matcher

I have my node running, but I am trying to configure the matcher, but when I try to curl -X POST --header ‘Content-Type: application/json’ --header ‘Accept: application/json’ -d ‘random’ ‘127.0.0.1:6869/utils/hash/secure’ it then says:

curl: (7) Failed to connect to 127.0.0.1 port 6869: Connection refused

I added to port to my security group in AWS
And I already ran netstat and port shows listening

Ciao.

I have a node, you have to study a lot from personal experience.
I know that the matcher must be installed separately from version 1.0.0 or something like that.
Try taking a look at these links: Private Node Matcher
Matcher: https://github.com/wavesplatform/dex/releases
If someone can provide better help, it’s welcome.

1 Like

Thank you so much, I added the configuration to the matcher code, but when I curl the matcher it doesn’t show the address I wrote, is it normal? Like the matcher uses a different address? Maybe we can work together to make a detailed guide on setting up everything, because I’m trying to build up my DEX but I find Waves documentation a bit confusing.

True, the waves documentation is confusing and difficult for me too.
Ei, I’m Italian and as soon as I can I would like to create video guides in Italian with English subtitles, we hope to create quality material.

I suppose you’re using deb.
The basic configuration of the dex.conf file should be this:

waves{
  extensions = ["com.wavesplatform.dex.Matcher"]

  dex {
    # Matcher's account address
    # account = ""

    # Matcher REST API bind address
    bind-address = "127.0.0.1"

    # Matcher REST API port
    port = 6886
  }
}

I believe the configuration is this:

waves{
  extensions = ["com.wavesplatform.dex.Matcher"]

  dex {
    # Matcher's account address
    account = "ADDRESS WALLET NODE"

    # Matcher REST API bind address
    bind-address = "ADDRESS IP VPS"

    # Matcher REST API port
    port = 6886
  }
}

Did you stop the knot before this?
command stop:
sudo systemctl stop waves

command start:
sudo systemctl restart waves.service

Yes I am using deb, here’s my conf:

waves {
blockchain.type = MAINNET
network {
port = 6868
node-name = " Node"
declared-address = “1.2.3.4:6868”
known-peers = [
“13.228.86.201:6868”
“13.229.0.149:6868”
“18.195.170.147:6868”
“34.253.153.4:6868”
“35.156.19.4:6868”
“52.50.69.247:6868”
“52.52.46.76:6868”
“52.57.147.71:6868”
“52.214.55.18:6868”
“54.176.190.226:6868”
]
}
wallet {
password = “Pass!”
seed = “1HJKEHo4bUEbAz3”
}
rest-api {
enable = yes
api_key_hash = “1234455”
bind-address = “0.0.0.0”
port = 6869
}
} waves.extensions = [“com.wavesplatform.dex.Matcher”]
waves.dex {
account = “3PNKdxsFysKPi”
}
matcher {
enable = yes
account = “3PNKdxsFy4”
bind-address = “0.0.0.0”
port = 6886
}
include “local.conf”

Thanks for your help

My last response was flagged I don’t know why, yes I am using deb and I stopped the service then changed the conf, do I need to use:
Matcher {
enable = yes
account = “accountaddress”
}

Or just the dex configuration?

The message is marked because you entered the basic seed 58 I believe.
The seed never has to see anyone, ever!
You have posted waves.conf quite strange for me, maybe I’m wrong but that doesn’t work
The matcher must be installed separately and configured separately as far as I know, you should configure dex.conf or something like that.
What you have published and then obscured is very altered waves.conf and matcher no longer has to be there.
As I see it, the node will never work.
Version of the node?
What is the name of the node?
Did you say that the node is running, in the terminal somewhere are you reading “microblock”?
I have to go now, you can write me in pm.

I know about the seed, I didn’t post it, I just posted random characters it wasn’t my seed.

Yes I have a running node, I can see it in dev.pywaves.org/nodes