Urgent Help Please.


#1

Yesterday on Waves Platform I placed an order to sell Kolin at 2 Sats on the BTC market. I was puzzled as it didn’t seem to execute into a pending order which will be pending until the price hits 2 sats, so I tried exactly the same amount again and it still didn’t seem to work.

I then looked at my order history and it excuted in Waves despite me keying it in BTC Sats. Not only that but it executed at 3000 Wavetoshi which is approximately 60% less than 2 Sats so I have lost a huge amount of money due to what I think is a bug.

I reached out to Waves Support and they don’t want to help me. They are saying that I am mistaken and that I must’ve keyed it wrong. I did not key it wrong. I asked to sell at 2 sats. Not 3000 Wavetoshi. They are basically accusing me of lying. They asked me to send them a video of me using the website and going into the order section. It seemed normal so they said they won’t help me.

Earlier today I did an experiment and I tried to replicate this. I placed 3 orders to sell 1 kolin at 2 sats on BTC and they all got sold at 3500 wavtoshi even though I asked to sell at 2 Sats. I managed to record this on my phone as I was doing it and I sent it to Support and your telegram and they are still accusing me of lying. They are saying I need to send a video of me using my phone with a timestamp and filming myself as I do it.

Can somebody please help me? This looks to me like a bug. And it’s a bug that has lost me roughly 60% of my money yesterday. I understand that this may have happened previously on the website. Can anyone suggest what the best way forward is. I would like to be reimbursed for what I have lost. I’m very distressed about losing what is a lot of money for me through no fault of my own.


#2

This post was flagged by the community and is temporarily hidden.


#3

You did not provide any links to your account or problem transactions.

You are claiming you got the video, but there is only words in your post.

When you work with blockchains you can always proof everything. So proofs please.


#5

OK, i checked your video, there is no bug or problems at all, just misunderstanding.

  1. You are trading in Kolin / BTC pair when selling
  2. But you are looking at Kolin / WAVES pair @ My Trade History

It is different pairs with different costs, be more attentive.


#6

You’ve not watched the video at all. And you’ve not read my post properly. I’ll break it down slowly for you:

  1. I set an order yesterday at 2 Sats on the BTC market for Kolin on the video.

  2. I clicked sell at 2 Sats on the BTC market.

  3. That Sell should have stayed pending until someone buys my sell at 2 Sats

  4. It didn’t stay pending.

  5. It excuted in Waves despite me selling in Sats

  6. The sell excuted at 3502 Wavetoshi which is just under a sat in BTC.

  7. Yesterday’s sell that I didn’t get on video executed at 3000 Wavetoshi which is 0.75 Sats even though I clicked to sell at 2 Sats on the BTC market. This caused me to lose 60% of my Money through no fault of my own. This was a very large amount of money for me.

  8. Exactly how should I be more attentive? I asked to sell at 2 Sats and the sell should execute at 2 Sats. Not 3000 Wavetoshi

  9. That is a bug which has caused me to lose money and potentionally others too.

  10. You seem to be indirectly accusing me of lying which is totally unfair.

I look forward to hearing your response.


#7

Sorry mate, i checked once again and found your transactions, seems there is a bug in UI:
http://wavesexplorer.com/tx/GuKqBcCAnqHmAdaGj4Yjcq2Uc6sQtqKrEht7GVkHvWRM
https://nodes.wavesnodes.com/transactions/info/GuKqBcCAnqHmAdaGj4Yjcq2Uc6sQtqKrEht7GVkHvWRM

If you really did not done some source code changes in your waves client then it looks like there is a bug with UI which caused your problem.

This bug shows you that you are on Kolin / BTC pair but in inner logic you are still in Kolin / WAVES pair, and when you place an order with 0.00000002 price it is placed on Kolin / WAVES pair instead of Kolin / BTC and matched with 0.00003520 price as it is first on the list.

I don’t know how to trigger this bug, but UI bugs are possible and depends on many factors, one of them is a mobile browser which can cause unpredictable behavior in your specific scenario.

I recommend you to install Waves Keeper to check everything you sign (and maybe change your browser when work with the client).

And Waves Team should double check their UI in the BUY / SELL block.


#8

Thank you. I’m glad someone finally has listened to me. I’m banging my head against the wall with Waves Support team. They don’t want to listen. So if it is a UI fault is that a problem with the actual website itself? It’s nothing I’ve done. I used the Safari browser on iOS. The reason I’m so upset is that on Wednesday I placed an order to sell 12m at 2 sats. Nothing happened that I could see. So I tried it again. Same thing. I then realized that it had executed at 3000 Wavetoshi. So I lost money twice. Is it an actual problem with their website? If it is, I believe they should refund me.


#9

Not the whole amount of course but the difference between the waves and BTC price.


#10

Hello, mtuk1!

I am the head of technical support of Waves platform. I am very sorry that you had this situation. First of all, I ask you to understand the whole situation correctly. The support agent should always get the complete information about the problem so that he can repeat the problem and forward the entire report to the QA department. It is required to get the most accurate and fast result in solving a particular problem. Thus, I am sorry that you accepted our requests as an attempt to accuse of lying.

So, we asked you for more details for our QA department that they could do a more in-depth analysis. Since we work in the blockchain space, almost every action needs to be tested using different methods because your situation can be perceived from different sides.

On the two videos provided earlier, unfortunately, it is impossible to prove or disprove any actions before recording a video. For this reason, we asked you to give a more detailed video, but unfortunately, we did not receive any answer from you and eventually met here. :slightly_smiling_face:

To make my words believable, I will provide some screenshots of our correspondence.

In any case, we already forward all available information to the QA department and will contact you as soon as we get a solution or additional information for you. Please use the created ticket - https://support.wavesplatform.com/helpdesks/3/tickets/24933-regarding-support-ticket-22395